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COMPUTER APPLICATION FOR MASS MEDIA 

UNIT-I Introduction to Computers – Block diagram of a computer, History and generation 
of computers, types of computer – Analog, Digital, Hybrid, parts of computer – 
hardware & software, input and output devices, Storage Devices, Memory, 
characteristics of computer, types of software. 
Operating System – Introduction, functions, types. 
 

UNIT-II Introduction to Windows – features of Windows 95, 98, XP. Internet – Introduction 
to Internet, usefulness of Internet, Advantages and Disadvantages. 
 

UNIT-III MS – Word – Word Processor, various editing features, various menus – File, Edit, 
View, Insert, Format, Tools, Table, Window, Help and options available, Hyperlink, 
Header Footer, Mail Merge, Table feature, Inserting Objects, advantages of word 
processor. 
 

UNIT-IV MS – Excel – Spread Sheet, various packages – Lotus 1-2-3, Excel. Features of spread 
sheet, Inserting chart, Hyperlink, Header and Footer, Data Functions, Goal seek, Pivot 
Table & Report, Auditing features. 
 

UNIT-V MS – PowerPoint – Introduction to PowerPoint, Various types of slides, various 
animation features, effects, Inserting objects in a slide, various slide show reviewing 
options, slide design, slide design, slide show, slide Transition. 
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UNIT-I 
COMPUTER 
Any digital computer carries out five functions in gross terms: 

 Takes data as input. 

 Stores the data/instructions in its memory and can use them when required. 

 Process the data and convert it into useful information. 

 Output the information. 

 Control all the above four steps. 

 
Block diagram of computer  
 

 
 
Components of Computer System 
Computer system is made up of a number of components. These are 

1. Input devices 
2. Memory unit 
3. Central processing unit 
4. Output devices 
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Advantages 
HIGH SPEED 

 Computer is a very fast device. 

 It is capable of performing addition of very big data. 

 The computer has units of speed in microsecond, nanosecond and even the picoseconds. 

 It can perform millions of calculations in a few seconds as compared to man who can spend 
many months for doing the same task. 

ACCURACY 

 In addition to being very fast, computer is very accurate. 

 The computer has performed calculations 100% error free. 

 Computers perform all jobs with 100% accuracy. 
STORAGE CAPABILITY 

 Memory is a very important characteristic of computers. 

 The computer has much more storage capacity than human beings. 

 It can store large amount of data. 

 It can store any type of data such as images, videos, text, audio and any other type. 
DILIGENCE 

 Unlike human beings, a computer is free from monotony, tiredness and lack of 
concentration. 

 It can work continuously without creating any error and boredom. 

 It can do repeated work with same speed and accuracy. 
 
VERSATILITY 

 A computer is a very versatile machine. 

 A computer is very flexible in performing the jobs to be done. 

 This machine can be used to solve the problems relating to various different fields. 
RELIABILITY 

 A computer is a reliable machine. 

 Modern electronic components have failure free long lives. 

 Computers are designed to make maintenance easy. 
AUTOMATION 

 Computer is a automatic machine. 

 Automation means ability to perform the task automatically. 

 Once a program is given to computer i.e stored in computer memory, the program and 
instruction can control the program execution without human interaction. 

REDUCTION IN PAPER WORK 

 The use of computers for data processing in an organization leads to reduction in paper 
work and speeds up the process. 

 As data in electronic files can be retrieved as and when required,the problem of 
maintenance of large number of files gets reduced. 

REDUCTION IN COST 

 Though the initial investment for installing a computer is high but it substantially reduces 
the cost of each of its transaction. 



 
B.A. (HONS.) Mass Communication II Semester                       Sub. – Computer Application for Mass 
Media 

 

 

45, Anurag Nagar, Behind Press Complex, Indore (M.P.) Ph.: 4262100, www.rccmindore.com 
4 

 

Disadvantages 
NO I.Q 

 A computer is a machine and has no intelligence of its own to perform any task. 

 Each and every instruction has to be given to computer. 

 A computer can not take any decision on its own. 
DEPENDENCY 

 It can perform function as instructed by user.So it is fully dependent on human being. 

 ENVIRONMENT 

 The operating environment of computer should be dust free and suitable to it. 

 NO FEELING 

 Computer has no feeling or emotions. 

 It cannot make Judgement based on feeling, taste, experience and knowledge unlike a 
human being. 

 
Computer Generations 
Generation in computer terminology is a change in technology a computer is/was being used. 
Initially, the generation term was used to distinguish between varying hardware technologies. But 
nowadays, generation includes both hardware and software, which together make up an entire 
computer system. 
There are totally five computer generations known till date.  
 
Following are the main five generations of computers 

S.N. Generation & Description 

1 
First Generation 
The period of first generation: 1946-1959. Vaccum tube based. 

2 
Second Generation 
The period of second generation: 1959-1965. Transistor based. 

3 
Third Generation 
The period of third generation: 1965-1971. Integrated Circuit based. 

4 
Fourth Generation 
The period of fourth generation: 1971-1980. VLSI microprocessor based. 

5 
Fifth Generation 
The period of fifth generation : 1980-onwards.ULSI microprocessor based 

 
First Generation 
The period of first generation was 1946-1959.    
First generation of computer started with using vacuum tubes as the basic 
components for memory and circuitry for CPU(Central Processing Unit). These 
tubes like electric bulbs produced a lot of heat and were prone to frequent fusing 
of the installations, therefore, were very expensive and could be afforded only by 
very large organizations. 
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In this generation mainly batch processing operating system were used. In this generation Punched 
cards, Paper tape, Magnetic tape Input & Output device were used. 
There were Machine code and electric wired board languages used. 
 
The main features of First Generation are: 

 Vacuum tube technology 

 Unreliable 

 Supported Machine language only 

 Very costly 

 Generate lot of heat 

 Slow Input/Output device 

 Huge size 

 Need of A.C. 

 Non portable 

 Consumed lot of electricity 
 
Some computer of this generation were: 

 ENIAC 

 EDVAC 

 UNIVAC 

 IBM-701 

 IBM-650 

 
 
Second Generation 
The period of second generation was 1959-1965. 
This generation using the transistor was cheaper, consumed less power, more 
compact in size, more reliable and faster than the first generation machines 
made of vacuum tubes. In this generation, magnetic cores were used as 
primary memory and magnetic tape and magnetic disks as secondary storage 
devices. 
In this generation assembly language and high level programming language like FORTRAN, COBOL 
was used. 
There was Batch processing and Multiprogramming Operating system used. 
 
The main features of Second Generation are: 

 Use of transistors 

 Reliable as compared to First generation computers 

 Smaller size as compared to First generation computers 

 Generate less heat as compared to First generation computers 

 Consumed less electricity as compared to First generation computers 

 Faster than first generation computers 

 Still very costly 

 A.C. needed 

 Support machine and assmebly languages 
 
Some computer of this generation were: 

 IBM 1620 

 IBM 7094 

 CDC 1604 

 CDC 3600 

 UNIVAC 1108 

Third Generation 
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The period of third generation was 1965-1971. 
The third generation of computer is marked by the use of Integrated Circuits 
(IC's) in place of transistors. A single I.C has many transistors, resistors and 
capacitors along with the associated circuitry. The I.C was invented by Jack 
Kilby. This development made computers smaller in size, reliable and 
efficient. 
In this generation Remote processing, Time-sharing, Real-time, Multi-programming Operating 
System were used. 
High level language (FORTRAN-II TO IV, COBOL, PASCAL PL/1, BASIC, ALGOL-68 etc.) were used 
during this generation. 
 
The main features of Third Generation are: 

 IC used 

 More reliable 

 Smaller size 

 Generate less heat 

 Faster 

 Lesser maintenance 

 Still costly 

 A.C needed 

 Consumed lesser electricity 

 Support high level language 
 
Some computer of this generation were: 

 IBM-360 series 

 Honeywell-6000 series 

 PDP(Personal Data Processor) 

 IBM-370/168 

 TDC-316 

 
Fourth Generation 
The period of Fourth Generation was 1971-1980. 
The fourth generation of computers is marked by the use of Very Large 
Scale Integrated (VLSI) circuits.VLSI circuits having about 5000 
transistors and other circuit elements and their associated circuits on a 
single chip made it possible to have microcomputers of fourth 
generation. Fourth Generation computers became more powerful, 
compact, reliable, and affordable. As a result, it gave rise to personal 
computer (PC) revolution. 
In this generation Time sharing, Real time, Networks, Distributed Operating System were used. 
All the Higher level languages like C and C++, DBASE etc. were used in this generation. 
 
The main features of Fourth Generation are: 

 VLSI technology used 

 Very cheap 

 Portable and reliable 

 Use of PC's 

 Very small size 

 Pipeline processing 

 No A.C. needed 

 Concept of internet was introduced 

 Great developments in the fields of 
networks 

 Computers became easily available 

 
Some computer of this generation were: 
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 DEC 10 

 STAR 1000 

 PDP 11 

 CRAY-1(Super Computer) 

 CRAY-X-MP(Super Computer) 
 

Fifth Generation 
The period of Fifth Generation is 1980-till date. 
In the fifth generation, the VLSI technology became ULSI (Ultra Large Scale 
Integration) technology, resulting in the production of microprocessor chips 
having ten million electronic components. 
This generation is based on parallel processing hardware and AI (Artificial 
Intelligence) software. 
AI is an emerging branch in computer science, which interprets means and 

method of making computers think like human beings. 
All the Higher level languages like C and C++, Java, .Net etc. are used in this generation. 
AI includes: 

 Robotics 

 Neural networks 

 Game Playing 
Development of expert systems to make decisions in real life situations. 
Natural language understanding and generation. 
 
The main features of Fifth Generation are: 

 ULSI technology 

 Development of true artificial intelligence 

 Development of Natural language processing 

 Advancement in Parallel Processing 

 Advancement in Superconductor technology 

 More user friendly interfaces with multimedia features 

 Availability of very powerful and compact computers at cheaper rates 
Types of Computer  
On the basis of working principle  
 
a) Analog Computer  
An analog computer (spelt analogue in British English) is a form of computer that uses continuous 
physical phenomena such as electrical, mechanical, or hydraulic quantities to model the problem being 
solved. .Example: Thermometer, Speedometer, Petrol Pump Indicator, Multimeter 

 
b) Digital Computer  
A computer that performs calculations and logical operations with quantities represented as digits, 
usually in the binary number system. 
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c) Hybrid Computer (Analog + Digital)  
A combination of computers those are capable of inputting and outputting in both digital and analog 
signals. A hybrid computer system setup offers a cost effective method of performing complex 
simulations.  
 
On the basis of Size  
a) Super Computer  
The fastest type of computer. Supercomputers are very expensive and are employed for specialized 
applications that require immense amounts of mathematical calculations. For example, weather 
forecasting requires a supercomputer. Other uses of supercomputers include animated graphics, fluid 
dynamic calculations, nuclear energy research, and petroleum exploration.  
b) Mainframe Computer  
A very large and expensive computer capable of supporting hundreds, or even thousands, of users 
simultaneously. In the hierarchy that starts with a simple microprocessor (in watches, for example) at 
the bottom and moves to supercomputers at the top, mainframes are just below supercomputers.  
c) Mini Computer  
A midsized computer. In size and power, minicomputers lie between workstations and mainframes. In 
the past decade, the distinction between large minicomputers and small mainframes has blurred, 
however, as has the distinction between small minicomputers and workstations. But in general, a 
minicomputer is a multiprocessing system capable of supporting from 4 to about 200 users 
simultaneously 
d) Micro Computer  

i. Desktop Computer: a personal or micro-mini computer sufficient to fit on a desk.  
       ii. Laptop Computer: a portable computer complete with an integrated screen and keyboard. It    is 
generally smaller in size than a desktop computer and larger than a notebook computer 

iii. Palmtop Computer/Digital Diary /Notebook /PDAs: a hand-sized computer. Palmtops have 
no keyboard but the screen serves both as an input and output device.  

e) Workstations  
A terminal or desktop computer in a network. In this context, workstation is just a generic term for a 
user's machine (client machine) in contrast to a "server" or "mainframe."  
Software 
Computer software is also known as computer programs. Software is the non-tangible component 
of computers. Computer software communicates with hardware and get the work done. 
Computer software includes all computer programs regardless of their architecture; for 
example, executable files, libraries and scripts are computer software.  
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Types of Software 
The computer software can broadly divide into two types. They are as follows:- 

 System software 

 Application software 
 
 

 
\ 
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System software is a program that manages and supports the computer resources and operations of 
a computer system while it executes various tasks such as processing data and information, 
controlling hardware components, and allowing users to use application software. 
 
Systems software works as a bridge between computer system hardware and the application 
software.  
Systems software is of three types. They are as follows:- 

 System management programs:- 
These are programs that manage the application software, computer hardware, and data 
resources of the computer system. 

 System support programs :- 
These are the programs that help the operations and management of a computer system. They 
provide a variety of support services to let the computer hardware and other system programs run 
efficiently. The major system support programs are system utility programs, system performance 
monitor programs, and system security monitor programs 

 System development programs 
 
These are programs that help users develop information system programs and prepare user programs 
for computer processing. These programs may analyze and design systems and program itself. The 
main system development programs are programming language translators, programming 
environment programs, computer-aided software engineering packages. 
 
Application software 
Application software consists of programs that direct computers to perform specific information 
processing activities for end users. Application software is further divided into two types they are as 
follows:- 

 General purpose software 

 Application specific software 
 
Language Translator: 
High level languages have been designed to give a better programming efficiency. High level language 
permits humans to write complex programs without going step-by-step. High level languages are 
application oriented. This is simplest and most widely used language for application development 
which overcomes the problem associated with assembly languages. It needed a translator to translate 
high-level language to machine codes (i.e. compiler and interpreter) 
Special software used to translate high level language to machine language for the operation of a 
computer before executing a program. 
 
Assembler: - A computer will not understand any program written in a language, other than its 
machine language. The programs written in other languages must be translated into the machine 
language. Such translation is performed with the help of software. A program which translates an 
assembly language program into a machine language program is called an assembler. If an assembler 
which runs on a computer and produces the machine codes for the same computer then it is called self 
assembler or resident assembler. 
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 Translates the assembly code into machine code; it also “assembles” the machine code into the main 
memory of the computer and makes it ready for execution. 
 
Compiler - Compiler is a system program which translates a high-level language program into machine 
language program is called a compiler. Compiler also checks error of the program to be executed. 
 
Features of the compiler:  
 
Compiler is more powerful than assembler. 
 
Limitation of the compiler: 

 Take longer time to produce result. 

 It occupies more memory space. 

 Low speed and low efficiency of memory utilization. 
 
Interpreter - It is also a translator which translates a high-level language program into object code, 
statement wise. It doesn’t translate the entire program at a time. It takes up one statement of a high-
level language program at a time, translates it and then executes it and then takes up the next 
statement and repeats the whole process till end. 
 
Features of the Interpreter: 

 Interpreter is cheaper than compiler. 

 It occupies less memory space. 

  
Limitations of the Interpreter: 

 Slower than compiler. 

 Suitable only for small programs. 
 
Input devices : - 
 Input devices are those device by which we can give input or information. 
Keyboard,  
The keyboard is an example of an input device that accepts data and translates it into electronic 
signals. The keyboard consists of a set of keys. There is one key switch for each letter, number, symbol 
etc, much like a typewriter. Most common keyboard is called QWERTY keyboard as the alphabets in 
the first row are placed like commonly used typewriters. When a key is pressed, the key switch is 
activated. 
 For example when you press the alphabet A on the keyboard, it is translated into the electronic code 
0100001, which is sent to the Computer. Similarly, the number 0 is translated into the electronic code 
00111001.  
 
Mouse 
Mouse is a pointing device which can be moved on a smooth surface to simulate the movement of 
cursor that is desired on the display screen. Mouse could be optical; offering quite and reliable 
operation, or mechanical which is cheaper.  There are 2 keys and scrolling facilities available in mouse. 
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Light Pen 
This is a pen shaped device allowing natural movement on the screen. The pen 
contains the Light receptor and is activated by pressing the pen against the display 
screen. Receptor is the scanning beam, which helps in locating the pen's position.  

 
Voice / Speech Input 
One of the most exciting areas of research is in recognizing human voices / speech so that this could 
form input to computer directly Voice recognition techniques along with several other techniques to 
convert the voice signals to appropriate words and derive the correct meaning of words are required 
for a commercially viable comprehensive speech recognition system. 
.  
Scanners 
Scanners facilitate capturing of the information (an image, text document, a drawing 
or a photograph) and storing them in graphic format for displaying back on the 
graphical screen.  

 
Magnetic Ink Character Recognition (MICR):  
These devices are generally used by the banking industry to read the account numbers on cheques 
directly and do the necessary processing. 
 

 
 
2. Optical Mark Recognition (OMR): These devices can sense marks on computer 
readable papers.. The optical mark recognition devices then directly read these 
answers sheets and the information sent to a computer for processing. The entrance 
tests and some of the assignments are being marked by OMR. 

 
 

3.Optical Bar Code Reader (OBR): These scans a set of vertical bars of different 
widths for specific data and are used to read tags and merchandise in stores, medical 
records, library books, etc. These are available as hand held devices.  
 
Output Devices 
An output device is a part of the computer system which is used to show results.  
 
Display Devices 
One of the most important peripherals in computer is the display device. Graphic display is made up of 
a series of dots called 'pixels' (picture elements) whose pattern produces the image. There are three 
categories of display screen technology; 
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1. Cathode Ray Tube (CRT) 
2. Liquid Crystal Display (LCD) 
3. Light Emitting Diaode(LED) 
4. Projection Displays 
 
CRT Displays 
The CRT (Cathode Ray Tube) monitor receives video signals from the computer and displays the video 
information as dots on the CRT screen. The main unit to the CRT monitor is the CRT itself; it is usually 
called a picture tube. The CRT is an evacuated glass tube with a fluorescent(phosphor) coating on the 
inner front surface, called screen. An electron gun at one end (neck) emits an electron beam. This 
beam is directed towards the screen. When the beam strikes the screen, the phosphor coating on the 
screen produces Illumination at the spot where the electron beam strikes. 

 
Liquid Crystal Displays (LCD) 
First introduced in watches and clocks in 1970s, LCD is now applied to display devices of a computer. 
The major advantage of LCD is the low energy consumption.,. The CRT is replaced by liquid crystal to 
produce the image. These also have colour capability but the image quality is relatively poor. 
 
Light Emitting diaode (LED)  
A light-emitting diode (LED) is a semiconductor light source. LEDs are used as indicator lamps in many 
devices and are increasingly used for general lighting. Appearing as practical electronic components in 
1962, early LEDs emitted low-intensity red light, but modern versions are available across the visible, 
ultraviolet, and infrared wavelengths, with very high brightness. 
 
Projection Displays 
A large screen upon which images are projected replaces the personal size 
screen of the previous displays. These are normally used for large group 
presentation. These systems can be connected to computer and whatever 
appears on the computer terminal gets enlarged and projected on e large 
screen. 

 
Printers 
Printer is a very common and popular output device. It accepts text and graphic output from a 
computer and transfers the information to paper, usually to standard size sheet of  paper. Printed 
output provides permanent record and is easy to copy and distribute. Generally we divide printers into 
two categories: impact and non-impact. 
 
Impact Printers 
Impact printers are printers that create characters by striking a print page with a print hammer (like in 
typewriter). The impact printers developed for use with computers work in much the same way as 
typewriters. 
 
 
 

http://en.wikipedia.org/wiki/Semiconductor
http://en.wikipedia.org/wiki/Lighting
http://en.wikipedia.org/wiki/Visible_spectrum
http://en.wikipedia.org/wiki/Ultraviolet
http://en.wikipedia.org/wiki/Infrared
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1. Dot Matrix Printer 
This is also a character printer. In the dot-matrix printer, an arrangement of tiny 
hammers strikes to produce the desired characters. Each hammer prints a small 
dot on the paper. 
 
2. Line Printer 
It prints a line at a time. In the line printer, raised characters extend the length of the drum. There are 
as many bands of type as there are printing positions.. Each band contains all the possible characters. 
The drum rotates rapidly, and one revolution is required to print eachline. A fast acting hammer 
opposite each band strikes the paper against the proper character as its passes. Thus, in one rotation, 
hammers of several positions may “fire” when the A row appears, several others may strike to imprint 
D's, etc. At the end of the rotation, the line has been printed. 
 
Non Impact Printers 
As their name implies, non-impact printer employ some process other than hammers or similar 
“percussion type'' mechanisms to form characters on a print page. It uses techniques such as ink spray, 
heat, Xerography or laser to form printed copy, i.e., characters are not formed by mechanical impact. 
Usually, non-impact printers are quieter than impact printer. 
 
1. Inkjet Printer 
It is a non-impact character printer. It fires a fine jet of dots of quick drying ink onto the paper to form 
character or dot graphics by using an electrostatic field. When Continuous stream inkjet printers are 
used, droplets of ink are electronically charged after leaving a nozzle.  
 
2. Laser Printers 
They are page printers, i.e., print a whole page at a time. Laser printers write the 
desired output image on a copier drum with a light beam that operates under 
computer control. A difference in a electric charge is created on those parts of the 
drum surface exposed to the laser beam.  
 
Central Processing Unit (CPU) 
The central processing unit (CPU) is where the actual processing takes place. This is where the 
calculations are performed and logical functions are carried out. 
There are broadly three parts of Central Processing Unit.  
Control Unit controls all the operations in computer.  
All the arithmetic and logic operations are performed in Arithmetic and logic unit (ALU).  
A set of registers is used for temporarily storing data or instructions in CPU. It is to be noted that the 
central processor is controlled by the instructions it gets from main memory. 
 
Computer Memory 
There are different types of memories, which are used in computer.  
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Main Memory 
Data and instructions are required to be stored in main memory from where it can be retrieved by 
central processing unit for processing results. Main memory serves as a temporary storage area for 
data and instructions. It is made up of a large number of cells, with each cell capable of storing one bit. 
The cells may be organized as a set of addressable words, each word storing a sequence of bits. The 
time to store and retrieve a word is independent of the address of the word. This organization is also 
called RAM or Random Access Memory. The main memory is very fast. Its storage capacity is in 
megabytes. Nowadays most of the Computers have minimum of 128 Mbytes of RAM. All the modern 
computers are now built with semiconductor main memory because of its fast access time, low cost, 
small physical size and low power consumption. RAM is further classified as either dynamic RAM 
(DRAM) or static RAM (SRAM) 
 

 
 

Secondary Memory 
The programs & data that are required to be used again & again are kept in auxiliary or secondary 
memory. Floppy disk, Hard disk are the examples of it. The present day capacity of Hard disk is 300 
Giga bytes. Because of its relatively slow speed auxiliary storage is used for storing programs and data 
not immediately needed by the Computer. Examples of Secondary memory are floppy disk, hard disk, 
magnetic tapes, charge-coupled devices, magnetic bubble memories, optical memories etc. 
 
Floppy Disk 
The floppy disk gets its name from the fact that it is made out of a flexible plastic material. The plastic 
base is coated with an iron-oxide recording substance that's similar to the material applied to the 
plastic ribbon of a magnetic tape. Data are recorded as tiny invisible magnetic spots on this coating.  
 
Hard Disk 
The disk described so far is the type of disks which can be removed from the disk drive and carried 
from place to place. Some disks however, are built into the computer or a special disk drive.. Hard 
disks can store anywhere from 20 MB to more than 40GB. Hard disks are also from 10 to 100 times 
faster than floppy disk. 
 
Magnetic Tapes 
Magnetic tapes are mounted on reels or a cartridge or a cassette of tape to store large volumes or 
backup data. These are cheaper and since these are removable from the drive, they provide unlimited 
storage capacity.  
 
CD-ROM 
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The CD-ROM (Compact Disk Read Only Memory) is a direct extension of audio CD. CD-ROM players are 
more rugged and have error correction facility. This ensures proper data transfer from CD-ROM to the 
RAM of the computer. CD-ROM is written using a CD writer. Information is retrieved from a CD-ROM 
using a low power laser, which ingenerate in an on optical disk drive unit.  
Cache Memory 
Cache memory is faster than the main memory. The cache memories although are fast yet are very 
expensive memories and are used in only small size. Thus, small cache memories are intended to 
provide fast speed of memory retrieval without sacrificing the size of memory. Cache memory stores a 
copy of the instructions and data to be immediately used of main memory. The memory reads or 
writes operation is first checked with cache memory and if the desired location data is available in 
cache memory then used by the CPU directly. 
 
Operating System (OS): An operating system is a program that acts as an interface between the user 
and the computer hardware and controls the execution of all kinds of programs. 

 
Following are some of important functions of an operating System. 

 Memory Management 
 Processor Management 
 Device Management 
 File Management 
 Security 

 Control over system performance 
 Job accounting 
 Error detecting aids 
 Coordination between other software 

and users 
 

TYPES OF OPERATING SYSTEM 
The categories are: 

 Real-time operating system (RTOS) - Real-time operating systems are used to control 
machinery, scientific instruments and industrial systems. An RTOS typically has very little 
user-interface capability, and no end-user utilities, since the system will be a "sealed box" 
when delivered for use. A very important part of an RTOS is managing the resources of the 
computer so that a particular operation executes in precisely the same amount of time, 
every time it occurs. In a complex machine, having a part move more quickly just because 
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system resources are available may be just as catastrophic as having it not move at all 
because the system is busy. 

 Single-user, single task - As the name implies, this operating system is designed to manage 
the computer so that one user can effectively do one thing at a time. The Palm OS for Palm 
handheld computers is a good example of a modern single-user, single-task operating 
system. 

 Single-user, multi-tasking - This is the type of operating system most people use on their 
desktop and laptop computers today. Microsoft's Windows and Apple's MacOS platforms 
are both examples of operating systems that will let a single user have several programs in 
operation at the same time. For example, it's entirely possible for a Windows user to be 
writing a note in a word processor while downloading a file from the Internet while printing 
the text of an e-mail message. 

 Multi-user - A multi-user operating system allows many different users to take advantage of 
the computer's resources simultaneously. The operating system must make sure that the 
requirements of the various users are balanced, and that each of the programs they are 
using has sufficient and separate resources so that a problem with one user doesn't affect 
the entire community of users. Unix, VMS and mainframe operating systems, such as MVS, 
are examples of multi-user operating systems. 

 
UNIT-II 

Window 95 
The new Windows operating system with the internal version 4.0 is the successor of Windows 3.11 
and brings a completely new design of the interface and of the kernel with it. 32-bit applications 
are supported fully, DOS applications can also virtually be used now in a DOS box, furthermore 16-
bits of programs are supported. Windows 95 to ME still needs DOS for the loading up program and 
for the DOS box. New hardware is comfortably recognized by plug and play, the memory 
management was developed further considerably.  
 
Features – 
- plug and play, high number of device drivers  
- high compatibility to DOS, Windows 3.x  
- high number of software  
- no multiprocessing  
- low local/network security  
- old system architecture (16-bit software compatibility)  
- badly scalable 
 
Window 98 
Microsoft announced with this new system software Version 4.10 the revised version of Windows 
95. The operating system Windows 98 contains as innovation mainly detail improvements and bug 
fixes. The hardware component is enhanced with USB support improved and the operation of 
several monitors is possible now. Windows 98 is prepared for DVD movies, for the view of DVD 
Movies a separate software must be installed.  
 
 



 

45, Anurag Nagar, Behind Press Complex, Indore (M.P.) Ph.: 4262100, www.rccmindore.com 
18 

 

Features : -  

 Multitasking: You can crash several programs all at once. No waiting!  

 Built-in Networking: You can crash several PC`s all at once. No need to buy Novell Personal 
Netware or LANtastic to crash.  

 Microsoft Network: Connect with other Windows 98 users and talk about your crash 
experiences. Support groups in different cities will be organized.  

 PnP: Plug and Pray (that it works)  

 Multimedia: Experience the immense sight and sound of crashing.  

 Compatible with existing software: It will also crash your existing software.  

 Increased Productivity: You will need to increase your budget to buy more products like 
RAM and HardDrives. Better yet, get a new computer! That`s product-ivity. 

 User-Friendly: Picture of clouds  

 State of the Art: Pay for Bill`s next bid for a work of art.  

 Macintosh-like: It took Microsoft 14 years and it`s not even original.  

 Online Registration: Dial into Microsoft and let them snoop around your harddrive. This will 
guarantee you a place in Microsoft`s files for the rest of your life.  

 MS Plus: More money for Bill`s plus side.  

 Optimize: It will increase the utilization of your hard drive and CPU so much so that you`ll 
end up upgrading your system. See "Increased Productivity". 

 
Window XP  
Windows XP is a computer operating system and  graphical user interface (GUI), which enables you 
to work with a wide variety of  programs on your computer, often simultaneously.  Windows XP is 
itself a special computer program that communicates your instructions to the  actual computer 
hardware, and displays the results.  
 
Features of Windows XP 
Standard features of Windows XP - Home and Professional 

 Fast user switching  

 Network assistant  

 Remote control for the diagnosis (Remote assistant)  

 Simplified user interface  

 Windows Media Player  

 Internet Explorer 6.0  

 Windows Movie Maker  
 
Special features of Windows XP - Professional Edition 

 ASR - Automated System Recovery  

 Create of offline files  

 Backup/recovery function  

 User guidelines (Policies)  

 User administration (limited in Home Edition)  

 File system encrypting (only for NTFS)  

 Integration of the PC in a domain  
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 Integration of dynamic data storage  

 Use as a terminal service client  

 Use as a NetWare-Client  

 Remote connection (desktop sharing)  

 Use of multiple monitors  

 EFS support in the file system  

 Send and receive Fax support  

 SMP (use of more than one processor)  
 

 Internet 
 The internet is a global network of interconnected computers, enabling users to share information 
along multiple channels. Typically a computer that connects to the internet can access information 
from a vast array of available servers and other computers by moving information from them to 
the computer’s local memory. 
 
From a social point of view – the internet is a device through which millions of people are 
communicating and sharing their idea and information. 
 
From a technical point of view – the internet is a network of thousands of computer networks. 
Together the networks making up the internet consist of over a mullion computer systems. 
 
Growth of internet: - internet started as a government project in the US, has spread all across the 
world connecting thousands of networks and millions of people Is an amazing truth today. The 
growth of internet can be estimated by the fact that users on internet were only 124 millions in 
2000 while it increased to 175 millions in 2004 only in the united states. the current internet 
subscriber base in India is 3.3 millions . 
 
Owner of internet: - the internet has no president nor has  it a CEO the ultimate authority on the 
internet is the internet society, which is a voluntary membership organization whose purpose is to 
promote global information exchange through the internet technology.  
 
Application of internet:-  

1. Business on internet 
2. Governance on/through internet 
3. Crime on internet 
4. Educational training 
5. Research  

 
Advantages of internet: 

1. Information 
2. Entertainment 
3. Services 
4. News 
5. E-commerce 
6. Communication 
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Disadvantages: 

1. Spamming 
2. Theft of personal details 
3. Pornography 
4. Virus threat 
5. Waste of time and money 

 
Internet terminology: -  
Internet browsers: 
Internet browser or web browser are software’s that allow you to explore the net.  
Some popular browsers are – 

• Microsoft Internet Explorer 
• Netscape Navigator 
• Mozilla Firefox 
• Google Chrome  
• Opera   

 
INTERNET SERVICE PROVIDER (ISP):-  
A company that provides internet access is known as internet service provider.  
including BSNL, Airtel   
 
Domain name systems(DNS): -  
DNS is a system that translates domain names into IP address. This is necessary because computers 
only make use of IP address yet we use only readable names since the name are easier to 
remember than IP address. 
 
Categories: -  
1. .com for commercial purpose like www.thinkdigital.com 
2. .edu for education domains like www.amity.edu 
3. .net for network, internet service provider and other network related companies like 
www.att.net 
4. .org for non government organization and non commercial like www.cry.org 
5. .mil for the united state military. 
 
Country level domain: - it is reserve for country. For example .in for India, .uk for united kingdom, 
.pk for Pakistan. 
 
WWW (World wide web) : -  
World wide web is a series of servers that are interconnected through hypertext. Tim burner lee is 
widely known as th father of the world wide web . burners was working with the European 
organization for nuclear research(CERN), in Switzerland).  
 
URL (Uniform resource locator) :-  URL is a type of uniform resource identifier that specifies where 
an identified resource is available and the mechanism for retrieving it. 
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Firewall: -  
A firewall is an executable code , the  attacker could compromise that code and execute from the 
firewall device. A firewall is a computer that sits between internal network and  the rest of the 
network and attempts to prevent bad things from happenings 
 
Virus :-  
A computer virus is a program or piece of code that is loaded onto your computer without you 
knowledge and runs against your wishes. All computer virus are man made. 
A few prominent virus are Michelangelo, dishwasher, C-brain , macmag , nenusalem , columbus  
etc. 
 
Antivirus : - a utility software that searches a hard disk for viruses and removes any that are found. 
Most antivirus programs include an auto update feature that enables the program to download 
profiles of nes virus so that it can check for the new viruses as soon as they are discovered. 
Some popular antivirus are NPAV, Quick heal ,Avast and Mac fee etc. 
 
Email basic :  
Email is a method of exchanging digital messages , designed primarily for human use. A message at 
least consists of its content , an author address and one of more recipient addresses.  
 
Features of email : 

1. Address book 
2. Statistics 
3. Sorting or mails 
4. Security 
5. Edfit/draft option 
6. File attachment 
7. Reply/forward option 

 
Types of email –  
1. Marketing Emails : - Marketing (or Bulk) emails stimulate your clients and leads. They 

contain informative / incentive messages. The recipient must agree to receive such emails: 
opt-in is mandatory. 
Examples : - Newsletters , Flash sales , Sales/promotions announcements 

2. Notification Emails:- Notification email are also known as trigger, alert or auto-responder. 
They allow the user to be notified each time a particular event happens (or has happened). 
More generally, the notification email may be used in order to celebrate and/or mark an 
event. 
Examples: - getting in touch a few days after registration , Congratulations after a status 
change (first purchase, subscription...) , Birthday email , Shopping Cart Abandonment email 

3. Transactional Emails: - This is an expected message and its content is information that the 
client wishes to check or confirm, and not "discover". This type of email is not intended to 
optimize the customer relationship but to define it and mark it out. It is a point of reference 
in one’s CRM. 
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Examples; - Welcome message / Account opening, Shipment tracking and order status, 
Order shipment confirmation, Account termination 

 
Free email sites are: -  

 www.google.com 

 www.yahoo.com 

 www.rediff.com 

 www.indiatimes.com 

 www.mail.com 
 

UNIT- III 
            WORD PROCESSOR 

 
A word processor is an electronic device or computer application software that performs word 
processing: the composition, editing, formatting and sometimes printing of any sort of written 
material. Word processing can also refer to advanced shorthand techniques, sometimes used in 
specialized contexts with a specially modified typewriter. 
The word processor emerged as a stand-alone office machine in the 1970s and 1980s, combining 
the keyboard text-entry and printing functions of an electric typewriter with a dedicated computer 
processor for the editing of text. 
 
Characteristics 
Word processing typically implies the presence of text manipulation functions that extend beyond 
a basic ability to enter and change text, such as automatic generation of: 

 batch mailings using form letter template and an address database (also called mail 
merging); 

 indices of keywords and their page numbers; 
 tables of contents with section titles and their page numbers; 
 tables of figures with caption titles and their page numbers; 
 cross-referencing with section or page numbers; 
 footnote numbering; 
 new versions of a document using variables (e.g. model numbers, product names, etc.) 

 
Examples of different word processing software are: 

 WordPerfect 
 Microsoft Word 
 WordMark 
 Lotus WordPro 
 Procedure Write 

 
Types of word processor:- 

 Dedicated word processor 
 Standard word processor software packages 
 Word processing packages on minicomputer 
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Features of Word : 
1) Word wrap  
2) Editing of text 
3) Page formatting 
4) Paragraph formatting 
5) Text formatting 

6) Retriving of your work 
7) Mail Merge  
8) Spelling & grammer check 
9) Use of thesaurus  
10) Online Assistant 

  
Each of the tabs contains the following tools: 
Home: Clipboard, Fonts, Paragraph, Styles, and Editing.  
Insert: Pages, Tables, Illustrations, Links, Header & Footer, Text, and Symbols 
Page Layout: Themes, Page Setup, Page Background, Paragraph, Arrange 
References: Table of Contents, Footnote, Citation & Bibliography, Captions, Index, and Table of 
Authorities 
Mailings: Create, Start Mail Merge, Write & Insert Fields, Preview Results, Finish 
Review: Proofing, Comments, Tracking, Changes, Compare, Protect 
View: Document Views, Show/Hide, Zoom, Window, Macros 
 
Create a New Document 
There are several ways to create new documents, open existing documents, and save documents in 
Word: 

 Click the Microsoft Office Button and Click New  or 
 Press CTRL+N on the keyboard 

 
Opening an Existing Document 

 Click the Microsoft Office Button and Click Open, or 
 Press CTRL+O on the keyboard, or 
 If you have recently used the document you can click the Microsoft Office Button and click 

the name of the document in the Recent Documents section of the window Insert picture 
of recent docs 

 
Saving a Document 

 Click the Microsoft Office Button and Click Save or Save As, or 
 Press CTRL+S on the keyboard, or 
 Click the File icon on the Quick Access Toolbar 

 
Renaming Documents 
To rename a Word document while using the program: 

 Click the Office Button and find the file you want to rename. 
 Right-click the document name with the mouse and select Rename from the shortcut menu. 
 Type the new name for the file and press the ENTER key. 

 
Working on Multiple Documents 
Several documents can be opened simultaneously if you are typing or editing multiple documents 
at once.  All open documents will be listed in the View Tab of the Ribbon when you click on Switch 
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Windows.  The current document has a checkmark beside the file name.  Select another open 
document to view it.  
 
Document Views 
There are many ways to view a document in Word.  

 Print Layout:  This is a view of the document as it would appear when printed.  It includes 
all tables, text, graphics, and images. 

 Full Screen Reading:  This is a full view length view of a document.  Good for viewing two 
pages at a time. 

 Web Layout:  This is a view of the document as it would appear in a web browser. 
 Outline:  This is an outline form of the document in the form of bullets. 
 Draft:  This view does not display pictures or layouts, just text. 

To view a document in different forms, click the document views shortcuts at the bottom of the 

screen  or: 
 Click the View Tab on the Ribbon 
 Click on the appropriate document view. 

 
Close a Document 
Click the Office Button 

 Click Close 
 
There are many features to help you proofread your document.  These include:  Spelling and 
Grammar, Thesaurus, AutoCorrect, Default Dictionary, and Word Count. 
 
Editing text selecting – to select text with the mouse use the following steps – 

1) Take the mouse pointer before the place you want to select text from and drag it to 
the place till you want.  

2) Select the text with keyboard  
 
Inserting & Deleting Text – You can insert or delete text in several ways.  

1) Select a block of text from beginning to the last character. To delete press Del key from the 
keyboard this process will delete the entire block.  

2) To delete single character use Del key or backspace key. 
3) To Insert the text select the text copy the text and paste the text where ever you want.  
4) There are different pasting options you can use.  

Formatting Features of Ms word:- 
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Function of commonly used buttons 

 

 
Select the style to apply to paragraphs   

 
Changes the font of the selected text  

 

 
Changes the size of selected text and 
numbers  

 

 
Makes selected text and numbers bold  

 

 
Makes selected text and numbers italic   

 
Underlines selected text and numbers  

 

Aligns to the left with a ragged right 
margin   

 
Centers the selected text  

 

Aligns to the right with a ragged left 
margin   

 
Aligns the selected text to both the left 
and right margins  

 

Makes a numbered list or reverts back 
to normal   

 
Add, or remove, bullets in a selected 
paragraph  

 

Decreases the indent to the previous tab 
stop   

Indents the selected paragraph to the 
next tab stop  

 

 
Adds or removes a border around 
selected text or objects  

 

 
Marks text so that it is highlighted and 
stands out  

 

 
Formats the selected text with the color 
you  

  

 
Text Selecting – 
You can select the text in two ways – 

 By using shift key  

 By using mouse 
Once the text is selected you can change the formatting of the selected text. You can delete, move 
the text from one position to other.  
 
Previewing the document – 
Before printing the documents you can preview the document. In preview option we can change 
the margin, page layout, size etc features of your document. The step to preview the document is 
as follows – 

1) Click MS-Office button  
2) Click on print button & then  
3) Click on print preview  
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Printing Document to a file page – 
You can print the document. There are two different features to print the document are as follow – 

3) Print – In print option you can change the number of copies, Select page no., choose 
printer etc before printing. 

4) Quick Print – In quick print the document is directly send to the printer without 
making any changes. 

 
 
Reduce the no. of pages by one – 
You can shrink the document pages to by one page. Attempt to shrink the document by one page 
by slightly reducing the size and spacing of the text. The option to reduce number of pages by one 
can be selected from Print Preview option.  

 
 
Paragraph Formatting  

 
 

Paragraph formatting provide us the facility to format the paragraph written in the document. The 
paragraph formatting include the formatting features – 

 Alignment – There are different alignments like left, center, rights & Justified.  
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 Line Spacing - In Line Spacing option you can change the spacing between the lines.  

 Shading – In this option you can Color the background of the selected text or paragraph.  

 Border – You can customize the border of the selected text or cell.  

 
 Sorting options - In sorting option we can sort the text in alphabetical order or numerical 

order. 

 Numbering / Bullets – We can create bullet list or numbering list through this option. 

 Indent – Indentation determine the distance of paragraph from either the left or right 
margin.   

 
Headers and Footers 
Header & footer may be text or graphics printed on top & bottom of the document. Header is 
printed on top margin area & footer is printed on bottom margin area.  
Headers and footers are pieces of text or graphics that appear at the top and bottom of a page. 
After you set up a header and footer, they will appear on all of your pages. You can add a page 
number to a header or footer, and Microsoft Word will automatically insert the right page number 
for you. 
To set up a header and footer for your document, click on the Insert tab at the top of Word. Now 
locate the Header & Footer panel: 

 
 
Footers 
Microsoft Word allows you to insert page numbers into your document. This is done (usually) in the 
Footer area of the page. The Footer is just the opposite of the Header. You can do the same things 
with the Footer as you can with the Header. We'll see how to insert page numbers into the Footer. 
Make sure the Design tab is select at the top of Word. Now locate the Navigation panel again. Click 
the item that says "Go to Footer": 
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Multiple Columns – 
With the use of multiple column option you can Spilt  
text into two or more columns. You can select this  
option from Page layout tab.  
 
 
 
 
 
 
 
 
 

 
UNIT – IV 

Microsoft’s EXCEL has become the standard for basic data analysis.  And, again, individuals with a 
college education in the 21st century will be expected to have a working knowledge of this 
foundational package.  EXCEL is critical to understand not only because it facilitates basic data 
analysis, but also because it is typically the starting point for PC-based data which can then be 
analyzed using more sophisticated packages like SPSS, Minitab or SAS. 
 
When you open EXCEL, the interface includes row and columns, with “cells” at the intersections.  
You can input data or formulas into the individual cells.   
 
Spreadsheets are made up of columns, rows  and their intersections are called cells. 
Column- In a spreadsheet the COLUMN is defined as the vertical space that is going up and down 
the window. Letters are used to designate each COLUMN'S location 
Row - In a spreadsheet the ROW is defined as the horizontal space that is going across the window. 
Numbers are used to designate each ROW'S location. 
Cell - In a spreadsheet the CELL is defined as the space where a specified row and column intersect. 
Each CELL is assigned a name according to its COLUMN letter and ROW number(A1). 
In a spreadsheet there are three basic types of data that can be entered.  

 labels - (text with no numerical value)  

 constants - (just a number -- constant value)  

 formulas* - (a mathematical equation used to calculate) 
 
To Create an Excel Workbook: 
Choose File New from the menu bar 
Choose Blank Workbook under the New category heading.  
A blank workbook opens in the Excel window. The New Workbook task pane is closed.  
 
To Save a new Workbook: 
Choose File Save As from the menu bar. The Save As Dialog Box appears.  
Click on the Save In: dropdown menu and locate where the file will be saved. Type a name for your 
file in the File Name: box.  Click the Save button 
 
To Save Changes Made to an Existing Workbook: 
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Choose File Save from the menu bar, or Click the Save button on the Standard toolbar.  
If you're saving the file for the first time and you do not choose a file name, Microsoft Excel will 

assign a file name for you. 
It is a good idea to Save frequently when working in a spreadsheet. You can quickly save your 

spreadsheet by using the quick-key combination Ctrl + S. 
 
To Open an Existing Excel 2003 Workbook: 
Choose File Open from the menu bar. 
 
To close an existing Excel 2003 Workbook: 
Choose File Close from the menu bar. The workbook in the Excel window is closed. 
 
To Enter Data into a Cell: 
Click the cell where you want to type information. Type the data. An insertion point appears in the 
cell as the data is typed. The data can be typed in either the cell or the Formula bar. Click the cell 
that contains the information to be changed.  Type the new entry. The old entry is replaced by the 
new entry.  
 
To Edit Information in a Cell: 
Method 1: Direct Cell Editing - Double-click on the cell that contains the information to be 
changed.  
Method 2: Formula Bar Editing - Edit the entry in the formula bar 
Click the cell that contains the information to be deleted.  Press the Delete key, or Right-click and 
choose Clear Contents from the shortcut menu. 

To Undo Recent Actions (typing, formatting, etc), One at a Time: Click the Undo button.  
To Undo Several Recent Actions at Once: Click the arrow next to the Undo button. Select the 
desired Undo operation(s) from the list 

To Redo an Undo Operation: Press the Redo button.  
To Redo several recent Undo actions at once: Click the arrow next to Redo button. Select the 
desired Redo operation from the list.  Microsoft Excel reverses the Undo operation.  
Selecting Multiple Cells 
The currently-selected cell in Excel is called the active cell. You can also select a group of adjacent 
cells, or a cell range. Many operations can be done against a cell range: move it, copy, it, delete it 
or format it.  
To Select All Cells in a Column or Row: 
Click the gray Column heading to select the entire column. (Click and drag the cursor across other 
column headings to select those columns 
Click the gray Row heading to select the entire row. (Click and drag the cursor down through the 
row headings select those rows 
 
To Select the Entire Worksheet: Click the gray rectangle in the upper left corner to select entire 
worksheet. 
Cut , Copy & Paste  
The Cut, Copy and Paste buttons are located on the Standard toolbar. The Cut, Copy and Paste 
operations also appear as choices in the Edit menu. The Cut, Copy and Paste operations can also be 
performed through shortcut keys: ctrl+c, ctrl+v, ctrl+x. 
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Copy - The Copy feature allows you to copy selected information from the spreadsheet and 
temporarily place it on the Clipboard, which is a temporary storage file in your computer's memory. 
The Paste feature allows you to select any of the collected items on the Clipboard and paste it in a 
cell of the same or different spreadsheet. 
Cut and Paste Cell Contents - The Cut feature allows you to remove information from cells in the 
spreadsheet. Information that is cut can be pasted in another cell, as long as the pasting occurs 
before you perform another operation. If you don't paste the cut information immediately, it is 
removed from the Office clipboard. 
Moving Information Using Drag-and-Drop 
Another way to move information from one cell to another is to use the drag-and-drop method. 
You use the cursor to point to the information to be moved and then drag the cell to its new 
location. 
Formula - A formula can be a combination of values (numbers or cell references) and math 
operators (+, -, /, *, =) into an algebraic expression.  
 
To Create a Simple Formula that Adds the Contents of Two Cells: 

 Type the numbers you want to calculate in separate cells (for example, type 128 in cell B2 
and 345 in cell B3).  

 Click the cell where the answer will appear (B4, for example).  

 Type the equal sign (=) to let Excel know a formula is being defined.  

 Type the cell number that contains the first number to be added (B2, for example).  

 Type the addition sign (+) to let Excel know that an add operation is to be performed.  

 Type the cell number that contains the first number to be added (B3, for example).  

 Press Enter or click the Enter button on the Formula bar to complete the formula 
 
To Create a Simple Formula using the Point and Click Method: 

 Click the cell where the answer will appear (B4, for example).  

 Type the equal sign (=) to let Excel know a formula is being defined.  

 Click on the first cell to be included in the formula (B3, for example).  

 Type the subtraction sign (-) to let Excel know that a subtraction operation is to be 
performed.  

 Click on the next cell in the formula (B2, for example).  
 
Complex Formulas Defined 
Simple formulas have one mathematical operation. Complex formulas involve more than one 
mathematical operation. The order of mathematical operations is very important. If you enter a 
formula that contains several operations--like adding, subtracting and dividing, The order of 
operations is: 

 Operations enclosed in parenthesis  

 Exponential calculations (to the power of)  

 Multiplication and division, whichever comes first  

 Addition and subtraction, whichever comes first  
 
Filling Formulas to Other Cells 
The fill formula method allows you to copy a formula and fill it into many different consecutive cells 
at the same time.The mouse pointer changes to a black crosshair when passed over the fill handle, 
or the square box in the lower right corner of the cell. 
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To Use the Fill Handle to Copy a Formula to a Surrounding Cell: 

 Click on the cell that contains the formula to be copied.  

 Position the mouse pointer over the fill handle.  

 Click and hold the left mouse button, and then drag the contents to the cell that's to receive 
the fill formula.  

 Release the mouse button.  

 Select the Copy Cells option in the fill formula drop-down menu. 
 
Using Functions 
A function is a pre-defined formula that helps perform common mathematical functions. Functions 
save you the time of writing lengthy formulas. You could use an Excel function called Average, for 
example, to quickly find the average of range of numbers. Or you could use the Sum function to 
find the sum of a cell range. Excel contains many different functions. Each function has a specific 
order, called syntax, which must be strictly followed for the function to work correctly. 
 
Syntax Order: 

 All functions begin with the = sign.  

 After the = sign define the function name (e.g., Sum).  

 If there is more than one argument, separate each by a comma.  
An example of a function with one argument that adds a range of cells, B3 through B10: 

 
 
An example of a function with more than one argument that calculates the average of numbers in a 
range of cells, B3 through B10, and C3 through C10: 

 
Excel literally has hundreds of different functions to assist with your calculations.  There are many 
different functions in Excel 2003. Some of the more common functions include: 
 
Statistical Functions: 

 SUM - summation adds a range of cells together.  

 AVERAGE - average calculates the average of a range of cells.  

 COUNT - counts the number of chosen data in a range of cells.  

 MAX - identifies the largest number in a range of cells.  

 MIN - identifies the smallest number in a range of cells.  
 
Financial Functions: 

 Interest Rates  

 Loan Payments  

 Depreciation Amounts  
 
Date and Time functions: 
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 DATE - Converts a serial number to a day of the month  

 Day of Week  

 DAYS360 - Calculates the number of days between two dates based on a 360-day year  

 TIME - Returns the serial number of a particular time  

 HOUR - Converts a serial number to an hour  

 MINUTE - Converts a serial number to a minute  

 TODAY - Returns the serial number of today's date  

 MONTH - Converts a serial number to a month  

 YEAR - Converts a serial number to a year  
 
To Name a Worksheet:- Double-click the sheet tab to select it. The text is highlighted by a black 
box. 

 

 
 
Type a new name for the worksheet. 

 

 
 
Press the Enter key.  
The worksheet now assumes the descriptive name defined.  
 
Inserting Worksheets 
By default, each new workbook in Excel  defaults to three worksheets named Sheet1, Sheet2 and 
Sheet3. You have the ability to insert new worksheets if needed or delete others you no longer 
want. 
To Insert a New Worksheet: 
Choose Insert Worksheet from the menu bar. 
 

 
A new worksheet tab is added to the bottom of the screen. It will be named Sheet4, Sheet5 or 
whatever the next sequential sheet number may be in the workbook.  
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Deleting Worksheets - Any worksheet can be deleted from a workbook, including those that have 
data in it. Remember, a workbook must contain at least one worksheet. 

Click on the sheet(s) you want to delete. Choose Edit Delete Sheet from the menu bar. 

 
The following dialog box appears if the sheet being deleted contains information on it. 
Click the Delete button to remove the worksheet and all the data in it.  

 
Moving Worksheets 
When you move a sheet, you are moving it to a new location in this or another workbook. 
Select the worksheet you want to move/copy. Choose Edit Move or Copy from the menu bar. 

 
 
In the Move or Copy dialog box, use the drop down boxes to select the name of the workbook you 
will move the sheet to (the current workbook is the default). Also define where you want the sheet 
positioned in the workbook. 

 
Click the OK button to move the worksheet to its new location.  
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Copying Worksheets 

 Select the worksheet you want to move/copy.  

 Choose Edit Move or Copy from the menu bar.  

 In the Move or Copy dialog box, use the drop down boxes to select the name of the 
workbook you will copy the sheet to (the current workbook is the default). Also define 
where you want the sheet positioned in the workbook.  

 Click the Create a copy checkbox. 

 
 Click OK to create an exact copy of the worksheet and move it to the location specified.  

 
Inserting a row 

 Click anywhere in the row below where you want to insert the new row.  

 Choose Insert Rows from the menu bar. 
OR 

 Click anywhere in the row below where you want to insert the new row.  

 Right-click and choose Insert from the shortcut menu. 
 
To Insert a Column: 
Click anywhere in the column where you want to insert a new column. Choose Insert Columns 
from the menu bar. 

 
A new column is inserted to the left of the existing column.  
OR  

 Click anywhere in the column where you want to insert a new column.  

 Right-click and choose Insert from the shortcut menu. 
 
Deleting columns and rows 

 Select a cell in the row to be deleted.  

 Choose Edit Delete from the menu bar.  
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 Click the Entire Row radio button in the Delete dialog box. 

  
 Click the OK button.  

 
To Delete a Column and All Information in it: 

 Select a cell in the column to be deleted.  

 Choose Edit Delete from the menu bar.  

 Click the Entire Column radio button in the Delete dialog box. Click the OK button.  
 
Adjusting column widths 
By default, Excel's columns are 8.43 characters wide, but each individual column can be enlarged to 
240 characters wide. 

 
You can adjust column width manually or use AutoFit. 

 
To Manually Adjust a Column Width: 

 Place your mouse pointer to the right side of the gray column header.  

 The mouse pointer changes to the adjustment tool (double-headed arrow). 
 
Adjusting row height 

 Place your mouse pointer to the lower edge of the row heading you want to adjust.  

 The mouse pointer changes to the adjustment tool (double-headed arrow). 
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Drag the Adjustment tool up or down to the desired height and release the mouse button. 

 
 
To AutoFit the Row Height: 

 Place your mouse pointer to the lower edge of the row heading you want to adjust.  

 The mouse pointer changes to the adjustment tool (double-headed arrow).  

 Double-click to adjust the row height to "AutoFit" the font size.  
 
Understanding the Different Chart Types 
Area Chart - An area chart emphasizes the trend of each value over time. An area chart also shows 
the relationship of parts to a whole. 

 
 
Column Chart - A column chart uses vertical bars or columns to display values over different 
categories. They are excellent at showing variations in value over time. 

 
 
Bar Chart - A bar chart is similar to a column chart except these use horizontal instead of vertical 
bars. Like the column chart, the bar chart shows variations in value over time. 

 
 
Line Chart - A line chart shows trends and variations in data over time. A line chart displays a series 
of points that are connected over time. 
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Pie Chart - A pie chart displays the contribution of each value to the total. Pie charts are a very 
effective way to display information when you want to represent different parts of the whole, or 
the percentages of a total. 

 
Other charts that can be created in Excel  include: Doughnut; Stock XY (scatter); Bubble; Radar; 
Surface; or Cone, Cylinder, and Pyramid charts.. 
 
The AutoFilter feature makes filtering, or temporarily hiding, data in a spreadsheet very easy. This 
allows you to focus on specific spreadsheet entries. 
To Use AutoFilter: 
Select Data from the main menu.  
Select Filter  AutoFilter.  
Click the drop-down arrow next to the heading you would like to filter.  
For example, if you would like to only view data from the West Sales Region, click the drop-down 
arrow next to Sales Region. 
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Choose the data you would like to display. 
In this example, you would choose West. All other data will be filtered, or hidden, and only the 
West Sales Region data is visible. 

Click the drop-down arrow again and select All to display all of your original data. 
Sorting lists is a common spreadsheet task that allows you to easily reorder your data. The most 
common type of sorting is alphabetical ordering, which you can do in ascending or descending 
order.  
In this example, we will alphabetize the employee names. 
To Sort in Ascending or Descending Order: 
Select Data from the main menu.  
Select Sort. The Sort dialog box will appear.  
Select the category you would like to Sort by.  
Select Ascending to sort in alphabetical order from A to Z.  
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Click OK.  
 

 
To sort in reverse alphabetical order from Z to A, select Descending. 

 
To Sort Multiple Categories: 
Select Data from the main menu.  
Select Sort. The Sort dialog box will appear.  
Select the category you would like to Sort by.  
Select Ascending to sort in alphabetical order from A to Z.  
In the Then by section, select the second category you would like to sort.  
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Click OK to sort in alphabetical order and by sales region.  
 

 
 
 
Relative & Absolute Cell References 
Excel uses two types of cell references to create formulas.  Each has its own purpose.  Read on to 
determine which type of cell reference to use for your formula.   
 
Relative Cell References  
This is the most widely used type of cell reference in formulas.  Relative cell references are basic 
cell references that adjust and change when copied or when using AutoFill.  
Example:  
=SUM(B5:B8), as shown below, changes to =SUM(C5:C8) when copied across to the next cell.  
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Absolute Cell References  
Situations arise in which the cell reference must remain the same when copied or when using 
AutoFill.  Dollar signs are used to hold a column and/or row reference constant.  
Example:  
In the example below, when calculating commissions for sales staff, you would not want cell B10 to 
change when copying the formula down.  You want both the column and the row to remain the 
same to refer to that exact cell.  By using $B$10 in the formula, neither changes when copied.  
 

 
 

 
 
What-If Analysis tools 
There are three What-If analysis tools that you can use. To access these, select the Data tab and 
locate the What-If Analysis command. If you click this command, a menu with three options 
appears.  
 
Goal seek is useful if you know the needed result but need to find the input value that will give you 
the desired result. In this example, we know the desired result (a $400 monthly payment) and are 
seeking the input value (the interest rate). 
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Goal Seek 
To use Goal Seek to determine an interest rate: 

 Select the Data tab. 
 Locate the Data Tools group. 
 Click the What-If Analysis command. A list of three options appears. 

 
 
Goal Seek is used to get a particular result when you're not too sure of the starting value. For 
example, if the answer is 56, and the first number is 8, what is the second number? Is it 8 
multiplied by 7, or 8 multiplied by 6? You can use Goal Seek to find out.  
Create the following Excel spreadsheet 

 
In the spreadsheet above, we know that we want to multiply the number in B1 by the number in 
B2. The number in cell B2 is the one we're not too sure of. The answer is going in cell B3. Our 
answer is wrong at the moment, because we has a Goal of 56. To use Goal Seek to get the answer, 
try the following: 

 From the Excel menu bar, click on Data 
 Locate the Data Tools panel and the What if Analysis item. From the What if Analysis menu, 

select Goal Seek 
 The following dialogue box appears: 

 
The first thing Excel is looking for is "Set cell". This is not very well named. It means "Which cell 
contains the Formula that you want Excel to use". For us, this is cell B3. We have the following 
formula in B3: 
= B1 * B2 
So enter B3 into the "Set cell" box, if it's not already in there. 
The "To value" box means "What answer are you looking for"? For us, this is 56. So just type 56 into 
the "To value" box 
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The "By Changing Cell" is the part you're not sure of. Excel will be changing this part. For us, it was 
cell B2. We're weren't sure which number, when multiplied by 8, gave the answer 56. So type B2 
into the box. 
You Goal Seek dialogue box should look like ours below: 

 
Click OK and Excel will tell you if it has found a solution: 

 
Click OK again, because Excel has found the answer. Your new spreadsheet will look like this one: 

 
 
Scenarios in Excel 
Scenarios come under the heading of "What-If Analysis" in Excel. They are similar to tables in that 
you are changing values to get new results. For example, What if I reduce the amount I'm spending 
on food? How much will I have left then? Scenarios can be saved, so that you can apply them with a 
quick click of the mouse. 
An example of a scenario you might want to create is a family budget. You can then make changes 
to individual amounts, like food, clothes, or fuel, and see how these changes effect your overall 
budget. 
We'll create a scenario to see what effect the various budgets cuts have. 

 From the top of Excel click the Data menu 
 On the Data menu, locate the Data Tools panel 
 Click on the What if Analysis item, and select Scenario Manager from the menu: 
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When you click Scenario Manager, you should the following dialogue box: 

 
We want to create a new scenario. So click the Add button. You'll then get another dialogue box 
popping up: 

 
 
Pivot Table 
A Pivot Table is way to present information in a report format. The idea is that you can click drop 
down lists and change the data that is being displayed. For example, choose just one student from 
a drop down list and view only his or her scores. 
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UNIT-V 
 

Microsoft PowerPoint 
Microsoft PowerPoint is a slide-based presentation program developed by Microsoft. It was 
officially launched on May 22, 1990, as a part of the Microsoft Office suite. 
Originally designed for the Macintosh computer, the initial release was called "Presenter", 
developed by Dennis Austin and Thomas Rudkin of Forethought, Inc.In 1987; it was renamed to 
"PowerPoint" due to problems with trademarks,  
 
Versions: 
Versions for Microsoft Windows include: 

 1990 PowerPoint 2.0 for Windows 3.0 
 1992 PowerPoint 3.0 for Windows 3.1 
 1993 PowerPoint 4.0 (Office 4.x) 
 1995 PowerPoint for Windows 95 (version 7.0; Office 95) 
 1997 PowerPoint 97 (version 8.0; Office 97) 
 1999 PowerPoint 2000 (version 9.0; Office 2000) 
 2001 PowerPoint 2002 (version 10; Office XP) 
 2003 Office PowerPoint 2003 (version 11; Office 2003) 
 2007 Office PowerPoint 2007 (version 12; Office 2007) 
 2010 PowerPoint 2010 (version 14; Office 2010) 
 2013 PowerPoint 2013 (version 15; Office 2013) 

 
Slide Masters and Templates 

Slide Masters are used to create consistent layouts throughout your presentation. Using masters 
you can format titles, backgrounds, colors, dates, times, and slide numbers. Changes made to the 
Master Slide and the Master Layouts are applied to all slides with that layout. 
Changing to the Slide Master View 
To edit the Slide Masters, click on the View tab and click the Master Slide button under 
the Presentation Views group. 

 
A Slide Master tab will appear next to the Home tab, and the slide sidebar on the left will display 
your presentation's Master Slide along with its accompanying layouts. 
To return to the normal view click on Close Master View. 
 
Modifying a Slide Master 
Once in the Master View, you can modify the Master Slides like any other slide. You can change the 
size and placement of placeholders, change the font, background, colors, etc. 
To change the theme and theme settings for your slide master use the options under the Edit 
Theme group, just as you would modify Theme settings from the Normal View. 
 
Adding & Deleting Layout Slides 
Different layouts will be available under the Master Slide depending on the Theme of your 
presentation. If you wish to add a new layout slide to an existing Master, either click the Insert 
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Layout button in the Edit Master group or right-click in the slide sidebar and choose Insert Layout. 
A new slide will appear in the sidebar. 
To delete a layout, select the layout slide and either use the Delete button in the Edit Master 
group, or right-click the slide in the sidebar and select Delete Layout. 
 
Creating a New Slide Master Template 
To create a new template using Master Slides, either clicks the Insert Slide Master button in 
the Edit Master group, or right-click in the slide sidebar and choose Insert Master Slide.  
 
Saving a Slide Master as a Template 
To save your Master Slide and Layouts as a template: 

 Click on the Office button and choose Save As. 
 In the File name box rename the template or keep the suggested name 
 In the Save as type menu choose PowerPoint Template (*.potx) 
 Click Save. 

 
Toolbars: 
Home Tab 
The Home tab includes basic functions for creating and manipulating a presentation. The toolbars 
that make up the Home tab include Clipboard, Slides, Font, Paragraph, Drawing, and Editing.  
 
Insert Tab 
Use the Insert tab to add a wide variety of content into a presentation including tables, charts, 
images, links, text boxes, audio, and video.  
 
Design Tab 
The Design tab provides a variety of options for designing and formatting a presentation. Use the 
Design tab to manipulate the page setup, color themes, and backgrounds of a presentation. The 
toolbars that make up the Design tab include Page Setup, Themes, and Background. 
 
Animations Tab 
Use the Animations tab to add, customize, and preview animations and transitions between slides. 
The toolbars that make up the Animations tab include Preview, Animations, and Transition to This 
Slide. 
 
Slide Show Tab 
Manage the settings for showing a presentation with the Slide Show tab. The toolbars that make up 
the Slide Show tab include Start Slide Show, Set Up, and Monitors. 
 
Review Tab 
The Review tab provides access to proofing features like spell check and also allows for embedding 
comments in a presentation. The toolbars that make up the Review tab include Proofing and 
Comments. 
 
View Tab 
The View tab presents a number of options to specify how to view a presentation such as hiding or 
displaying notes, hiding or displaying gridlines, zooming in and out, displaying in gray scale, and 
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more. The toolbars that make up the View tab include Presentation Views, Show/Hide, Zoom, 
Color/Grayscale, Window, and Macros. 
 
Create a New Presentation 
To create a new presentation, click the Microsoft Office button and select New. The New 
Presentation pop-up window will appear. From here, choose to start with one of Microsoft’s 
Installed Templates, Installed Themes, or a Blank presentation to create a customized presentation.  
 
Design a Presentation 
PowerPoint includes a number of ready-made design themes. These themes serve as the basis for 
the graphic design of a presentation. Each theme consists of a background design, placeholder 
layouts, a color palette, and font styles.  
 
Insert a New Slide 
To insert a new slide into a presentation, click the Home tab in the ribbon. In the Slides toolbar, 
select the New Slide button.  
 
Save the Presentation 
To save a presentation, click the Microsoft Office button and choose Save As.  
 
View :- 
The View buttons appear near the bottom of the screen. The diiffrent View options:- Normal view, 
Slider Sorter view, and the Slide Show view. 

Normal View  
Normal view splits your screen into three major sections: the Outline and Slides tabs, the 
Slide pane, and the Notes area. The Outline and Slides tabs are on the left side of your 
window. They enable you to shift between two different ways of viewing your slides. The 
Slides tab shows thumbnails of your slides.  

  

Slide Sorter View  
Slide Sorter view shows thumbnails of all your slides. In Slide Sorter view, you can easily 
add, delete, or change their order of your slides. 

  
Slide Show  

Use the Slide Show view when you want to view your slides, as they will look in your final 
presentation.  

 
Zoom:- 

Zoom  allows you to zoom in and zoom out on the window. Zooming in 
means the window gets larger so you focus in on an object. Zooming out means the window gets 
smaller so you can see the entire window. 
Editing and Formatting Text:- 
 
To enter text: 

 Select the slide where you want the text 
 Click in a Textbox to add text 

To select the text: 
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 Highlight the text by dragging the mouse. 
 
Copy and Paste 
To copy and paste data: 

 Select the text that you wish to copy 
 On the Clipboard Group of the Home Tab, click Copy 
 Select the text where you would like to copy the data 
 On the Clipboard Group of the Home Tab, click Paste 

To delete the text: 
 Highlight the text by dragging 
 Click delete. 
 
Formatting:- 
To format your text, first select it. Once the text you wish to format is highlighted, use the options 
in the Font and Paragraph groups under the Home tab to format your text. 

 
 
You can format a text box using the following:- 

 Ribbon 

 Quick Menu 
 
You can use formatting features to change the following:- 
 

 To change the font typeface 

 To change the font size 

 Font Styles and Effects 

 Change Text Color 

 WordArt 

 Change Paragraph Alignment 

 Indent Paragraphs 

 Text Direction 
 
Find and select option: 
Find option is used to find the text within the presentation. Select option provides three options to 
select the text they are:- 
Select All 
Select Text 
Select Text With Similar Formatting Features 
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Bullets and Numbered list option:- 
Bulleted lists have bullet points, numbered lists have numbers, and outline lists combine numbers 
and letters depending on the organization of the list. 
To add a list to existing text: 

 Select the text you wish to make a list 
 Click the Bulleted or Numbered Lists button 

To create a new list: 
 Place your cursor where you want the list in the document 
 Click the Bulleted or Numbered Lists button 
 Start typing 

Nested Lists 
A nested list is list with several levels of indented text. To create a nested list: 

 Create your list following the directions above 
 Click the Increase or Decrease Indent button 

Header and Footer option 
 

To add a header and footer in your presentation:- 
Click on the Insert tab, then on the Header & Footer button.  
The Date & Time and Slide Number buttons will bring up the same dialog box. 
 

                                             
 
1. Fixed and Automatic Dates  
2. Slide Number  
3. Footer  
4. Apply/Apply To All  
5. Preview  
6. Notes and Handouts  
 
You can add the text in footer box. 
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Paragraph Formatting 
 
To format your text, first select it. Once the text you wish to format is highlighted, use the options 
in the Font and Paragraph groups under the Home tab to format your text. 

 
 
 
You can use paragraph formatting features to change the following:- 
 
Change Paragraph Alignment:- 
Choose the appropriate button for alignment on the Paragraph Group. 

 Align Left:  the text is aligned with your left margin 

 Center:  The text is centered within your margins 

 Align Right:  Aligns text with the right margin 

 Justify:  Aligns text to both the left and right margins. 
 

Indent Paragraphs 

 Click the Indent buttons to control the indent.  

 Click the Indent button repeated times to increase the size of the indent. 
 
Text Direction 

 Click the Text Direction button on the Home tab 

 Click the selection 
 
Spell Check 
To check the spelling in a presentation: 

 Click the Review tab 
 Click the Spelling button 

 
Print a Presentation 
There are many options for printing a presentation.  They are: 

 Slides: The slides that you can, one slide per page 
 Handouts: 1, 2, 3, 4, 6 or 9 per page, in this option you can see more than one slide on one 

page. 
 Notes Page: This option contain the slides and the speaker notes. 
 Outline View: This will print the outline of the presentation. 

 
Inserting option in PowerPoint presentation:- 
Adding Picture 
To add a picture: 

 Click the Insert Tab 
 Click the Picture Button 
 Browse to the picture from your files 
 Click the name of the picture 
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 Click insert 
 To move the graphic, click it and drag it to where you want it. 

Adding Clip Art 
To add Clip Art: 

 Click the Insert Tab 
 Click the Clip Art Button 
 Search for the clip art using the search Clip Art dialog box 
 Click the clip art 
 To move the graphic, click it and drag it to where you want it 

Editing Pictures and Clip Art 
when you add a graphic to the presentation, an additional Tab appears on the Ribbon.  The Format 
Tab allows you to format the pictures and graphics.  This tab has four groups: 

 Adjust  
Picture Style 

 Arrange 
 Size 

You can create your own simple shapes and objects with the built in drawing tools. You can even 
add formatting effects to your shapes, including resizing, rotating, 3D effects such as shadows and 
beveling, and changing the color of all or part of the shape. 

Drawing Preset Shapes 
In the Insert command tab, the Shapes group contains several 
categories of shapes, including lines, basic shapes, block arrows, 
flowchart elements, stars and banners, and callouts. 
Drawing Custom Shapes 
To draw your own shapes you can use the freehand drawing 
tools, Curve, Freeform and Scribble.   
Create a Chart 
To create a chart: 

 Click the Insert tab on the ribbon 
 Click the type of Chart you want to create 
 Insert the Data and Labels 

Edit Chart Data 
To edit chart data: 

 Click on the chart 
 Click Edit Data on the Design tab 
 Edit data in the spreadsheet 

Modify a Chart 
once you have created a chart you can do several things to modify the chart.  
To move the chart: 

 Click the Chart and Drag it another location on the same slide, or 
 Copy it to another slide 
 Choose the desired location and click Paste 

Slide Sorter 
The Slide Sorter is very useful feature, it help designer to check overall design of the presentation. 
Slide sorter feature are helpful to: 

 View slides as small thumbnails or miniature images 
 Create animated transitions between slides  
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 Rearrange the order of the slides in your PowerPoint presentation 
 Rehearse and set the timings of slide timings in your presentation 

Slide Transitions 
Transitions are effects that are in place when you switch from one slide to the next.  To add slide 
transitions: 

 Select the slide that you want to transition 
 Click the Animations tab 
 Choose the appropriate animation or click the Transition dialog box 

To adjust slide transitions: 
 Add sound by clicking the arrow next to Transition Sound 

Modify the transition speed by clicking the arrow next to Transition Speed 
To apply the transition to all slides: 

 Click the Apply to All button on the Animations tab 
To select how to advance a slide: 

 Choose to Advance on Mouse Click, or 
 Automatically after a set number of seconds 

Slide Animation 
Slide animation effects are predefined special effects that you can add to objects on a slide.   To 
apply an animation effect: 

 Select the object 
 Click the Animations tab on the Ribbon 
 Click Custom Animation 
 Click Add Effect 
 Choose the appropriate effect 

Animation Preview 
To preview the animation on a slide: 

 Click the Preview button on the Animations tab 
Slide Show Options 
The Slide Show tab of the ribbon contains many options for the slide show.  These options include: 

 Preview the slide show from the beginning 
 Preview the slide show from the current slide 
 Set up Slide Show 

Set Up Slide Show  
This option allows you to set preferences for how the slide show will be presented. The options 
include: 

 Whether the show will run automatically or will be presented by a speaker 
 The looping options 
 Narration options 
 Monitor resolutions 
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